Customer Support Portal Unavailable

Major incident Portals Customer Support | Support.jira.1global.com
2023-11-06 13:55 BST · 2 hours, 6 minutes

Updates

Resolved

This incident is now resolved and our customer support portal is now available.

November 6, 2023 · 16:01 BST
Issue

1Global is currently investigating an issue that’s causing our customer support portal ( jira.truphone.com/servicedesk/ ) to be unavailable. We’ll provide updates as soon as they’re available.

November 6, 2023 · 13:55 BST

← Back