Connectivity - US LTE Data Sessions Degradation

Major incident Connectivity Data (North America)
2024-02-22 08:50 BST · 12 hours, 56 minutes

Updates

Resolved

Our partners have confirmed the full resolution of the incident affecting users in the US, and our internal metrics confirm this scenario. We will now proceed with the incident closure.

February 22, 2024 · 21:43 BST
Escalate

We are seeing issues again with MNOs in the US. We have engaged our partners to investigate and reach a resolution.

Updates will be provided as soon as they’re available.

February 22, 2024 · 13:35 BST
De-escalate

We are now observing normal registration patterns for LTE Data Sessions. We will keep this incident under monitoring to confirm the stability of our services.

February 22, 2024 · 11:00 BST
Issue

Our teams have detected a degradation in LTE data session creation in the United States starting at 08h50 GMT. Our engineering teams are investigating this issue with our partners with the highest priority.

Updates will be provided as soon as they’re available

February 22, 2024 · 10:40 BST

← Back