Connectivity - Data Session Degradation 3G/2G Services

Major incident Connectivity Data (North America) Data (Europe) Data (Asia and Oceania) Data (South and Central America) Data (Africa)
2024-03-19 21:00 BST · 1 hour, 46 minutes

Updates

Resolved

This incident is now resolved

March 19, 2024 · 23:21 BST
Monitoring

Network connectivity has returned to normal operating parameters. Our operations teams are maintaining close monitoring to ensure continued stability.

March 19, 2024 · 22:59 BST
Issue

1GLOBAL has detected an issue affecting 2G/3G services in several regions. We are investigating this issue with our partners and as soon as updates are available they will be shared.

March 19, 2024 · 22:47 BST

← Back