Connectivity - LTE Service Degradation | United Kingdom

Major incident Connectivity Data (Europe)
2024-05-15 16:10 BST · 29 minutes

Updates

Resolved

This incident has now been resolved

May 15, 2024 · 16:37 BST
Issue

1GLOBAL has detected mobile service degradation in the United Kingdom when using LTE. We are investigating this situation with our partners with urgency.

Updates will be provided as soon as they are available.

May 15, 2024 · 16:10 BST

← Back