UAE eSIM Downloads degraded

Minor incident Remote SIM Provisioning Consumer Discovery Service Machine to Machine
2024-07-08 10:00 BST · 1 week, 2 hours, 23 minutes

Updates

Resolved

After a thorough investigation with our partners, we have now observed a return to normal eSIM download activity in the UAE. Consequently, we will close this incident. However, our operations teams will continue to monitor the situation closely to ensure ongoing stability.

July 15, 2024 · 12:17 BST
Issue

UAE eSIM Downloads degraded

We would like to inform you about a trend we suspect is affecting esim downloads in UAE.

Over the past 48 hours, we have observed a significant decrease in download volumes, which is now around 50% of the usual trend.

This degradation is not observed in any other country besides UAE. Mobile data services are not being impacted.

Unfortunately, we are unable to identify specific users who are impacted as these do not translate into incoming errors on our end. Your support teams may observe user complaints specific to downloads in UAE.

We are actively reaching out to local parties to investigate what has changed.

Testing eSIM download through different ISPs may result in different outcomes.

We appreciate your patience as we try to further understand this matter.

The next update will be provided within the next 24 hours.

BR
1GLOBAL

July 10, 2024 · 19:00 BST

← Back