Connect API | OTA Delivery Delays

Minor incident Connect API Data Europe Asia North America Oceania South and Central America Africa
2024-10-03 10:56 BST · 14 hours, 19 minutes

Updates

Resolved

This incident has now been resolved

October 4, 2024 · 01:16 BST
Issue

GLOBAL has detected a delay in the delivery of Over-The-Air (OTA) updates to eSIMs. These updates are crucial for ensuring device connectivity, particularly in certain countries where immediate connectivity upon arrival is essential.

This will impact new users connecting for the first time in a given country.

Our dedicated teams are actively investigating this incident to identify and resolve the underlying issues. We are committed to restoring the timely delivery of OTA updates as quickly as possible and will provide you with updates as soon as they become available.

Recommended Actions for Users:

  • Keep Your eSIMs Connected: Ensure that your eSIM-enabled devices remain connected to the network and your eSIM is enabled. This will allow them to automatically receive the necessary OTA updates once they are dispatched.

Impacted Countries:

  • Vietnam
  • Venezuela
  • Ukraine
  • Thailand
  • Taiwan
  • Sri Lanka
  • Portugal
  • Philippines
  • Paraguay
  • Panama
  • Pakistan
  • Nicaragua
  • Mongolia
  • Macao
  • Korea, Republic Of
  • Kazakhstan
  • Japan
  • Indonesia
  • Greenland
  • Georgia
  • China
  • Cambodia
  • Brunei Darussalam
  • Botswana
  • Belarus
  • Bangladesh
October 3, 2024 · 10:56 BST

← Back