Data Services | 2G/3G/4G Degradation

Major incident Connect API Data Europe Asia North America Oceania South and Central America Africa IoT Data Europe Asia North America Oceania South and Central America Africa
2025-01-16 12:30 GMT · 11 hours, 22 minutes

Updates

Resolved

This incident is now resolved

January 16, 2025 · 23:52 GMT
Monitoring

We are beginning to see improvements, and users in the affected countries should start regaining access to data services. However, some instability may persist as services continue to normalize.

Our operations teams will remain vigilant, actively monitoring the situation until it is resolved.

New updates will be provided as soon as they’re available.

January 16, 2025 · 22:43 GMT
Issue

GLOBAL has detected a data service degradation affecting a subset of users roaming under 2G/3G/4G on the countries listed below.

We are currently working with our partners to resolve this issue.

Impacted Countries:

  • Belarus
  • Botswana
  • Georgia
  • Greenland
  • Kazakhstan
  • Nicaragua
  • Pakistan
  • Panama
  • Paraguay
  • Portugal
  • Ukraine
  • Venezuela
  • Canada

We sincerely apologize for any disruption caused and appreciate the patience and understanding of our users during this time and new updates will be provided as soon as they’re available.

1GLOBAL

January 16, 2025 · 18:45 GMT

← Back