Voice & Data Issues in the United States

Minor incident Enterprise/Compliance Connectivity Voice Services United States Data Services United States IoT Data North America
2025-02-08 08:30 · 9 hours, 6 minutes

Updates

Times are shown in Africa/Abidjan timezone
Resolved

Dear customer,

Through our service KPIs, we confirm that the previously reported incident is no longer occurring.

We will closely monitor our service for the next 24 hours to ensure long-term stability.

For any inquiries or additional help, please reach out to our Customer Services team available 24x7.

We apologize for any inconvenience this incident has caused on your service.
1GLOBAL Major Incident Team

February 8, 2025 · 17:31
De-escalate

Dear customer,

We are currently experiencing Data & Voice connectivity difficulties in the United States.

Customers from our IoT and Business customers may experience a lack of connectivity, consequently, Data and Voice services may be unavailable.

The root cause of this incident was traced back to one of our suppliers in the region, whereas planned change on their side caused unexpended impact on our services.

We have currently applied mitigation actions on our side to prevent further impacts on our services, nevertheless, these are propagating throughout our network still, meaning that some impacts still may be seen. Due to this, we will de-escalate this incident and continue to follow up.

Expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

February 8, 2025 · 11:14
Update

Dear customer,

We are currently experiencing Data & Voice connectivity difficulties in the United States.

Customers from our IoT and Business customers may experience a lack of connectivity, consequently, Data and Voice services may be unavailable.

We can see through our service indicators that the situation has improved dramatically. We can see that Data services indicators are quickly returning to normal values and we can see Voice services performing quite stable.

Even though we can see improvements, we are still working to restore full-service availability.

Expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

February 8, 2025 · 10:37
Update

Dear customer,

We are currently experiencing Data & Voice connectivity difficulties in the United States.

Customers from our IoT and Business customers may experience a lack of connectivity, consequently, Data and Voice services may be unavailable.

We can see some improvements in the region, nevertheless, some instability will still occur, namely, in Voice services. We continue to work on restoring the impacted services while at the same time closely monitoring our service level indicators.

Expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

February 8, 2025 · 09:35
Issue

Dear customer,

We are currently experiencing Data & Voice connectivity difficulties in the United States.

Customers from our IoT and business customers may experience a lack of connectivity, consequently, Data and Voice services may be unavailable.

The major incident team is currently working on mitigating the impacting services.

Expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

February 8, 2025 · 08:56

← Back