Data | Turkey 2G/3G - Service Degradation
Minor incident
Connect API
Data
Europe
2025-03-21 11:05 GMT
· 5 hours, 24 minutes
Updates
Issue
March 21, 2025 · 12:10 GMT
Dear Customer,
We are currently experiencing issues affecting 2G/3G in Turkey
An investigation is ongoing with our network partners to resolve this incident swiftly.
We sincerely apologize for any disruption caused and appreciate the patience and understanding of our users during this time.
Updates will be provided as soon as they’re available.
Thank you,
1GLOBAL
← Back