Data | United Kingdom LTE - Service Degradation

Minor incident Connect API Data Europe
2025-03-26 12:00 GMT · 55 minutes

Updates

Resolved

This incident has now been resolved

March 26, 2025 · 12:54 GMT
Issue

Dear Customer,

We are currently experiencing issues affecting LTE in the United Kingdom that may cause suboptimal user experience

An investigation is ongoing with our network partners to resolve this incident swiftly.

We sincerely apologize for any disruption caused and appreciate the patience and understanding of our users during this time.

Updates will be provided as soon as they’re available.

Thank you,
1GLOBAL

March 26, 2025 · 12:13 GMT

← Back