Data | 2G/3G Service Degradation

Major incident Connect API Data Europe Asia North America Oceania South and Central America IoT Data Europe Asia North America Oceania South and Central America
2025-05-19 22:05 BST · 2 hours, 2 minutes

Updates

Resolved

This incident has now been resolved

May 20, 2025 · 00:07 BST
Issue

Incident Summary
1GLOBAL has detected a service degradation affecting 2G and 3G services in roaming countries. This can affect connectivity and also the delivery of OTA updates to users.

We’re working with our roaming partners to investigate and mitigate the observed situation.

Main Impacted Countries

  • Indonesia
  • Colombia
  • Italy
  • Switzerland
  • Greece
  • Poland
  • United States of America
  • Peru
  • Mexico
  • Philippines
  • Austria
  • Canada
  • France

We sincerely apologise for any disruption caused and appreciate the patience and understanding of our users during this time.

1GLOBAL

May 19, 2025 · 22:54 BST

← Back