Service Degradation in United States - T-Mobile

Minor incident Enterprise/Compliance Connectivity Voice Services United States Data Services United States Connect API Data North America IoT Data North America
2025-09-10 08:33 BST · 22 minutes

Updates

Resolved

Dear customer,

Through our service performance indicators, we confirm that the previously reported incident is no longer occurring. The service appears healthy and stable, no longer exhibiting signs of performance issues.

We will closely monitor our service for 24 hours to ensure long-term stability.

For any inquiries or additional help, don’t hesitate to contact your usual support channels and points of contact.

We apologize for any inconvenience this incident has caused to your service.

Thank you,
1GLOBAL Major Incident Team

September 10, 2025 · 08:50 BST
Issue

Dear Customer,

We are currently experiencing a degradation of 1Global services in the United States of America.

Customers may perceive a loss of Voice, Data, and SMS services.

We have engaged our partner T-Mobile in the United States, and they acknowledged a radio outage on their side impacting around 1116 sites.

The 1GLOBAL major incident team is currently following up closely with our partner to ensure a quick resolution.

We expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

September 10, 2025 · 08:00 BST

← Back