Registration Issues in the Philippines

Major incident Enterprise/Compliance Connectivity Voice Services Roaming Data Services Roaming Connect API Data Asia IoT Data Asia
2026-03-17 08:28 GMT · 4 hours, 38 minutes

Updates

Resolved

Dear customer,

Through our service performance indicators, we confirm that the previously reported incident is no longer occurring.

We expected Voice, Data, and SMS to work without any issues.

We will closely monitor our service for 24 hours to ensure long-term stability.

For any inquiries or additional help, don’t hesitate to contact your usual support channels and points of contact.

We apologize for any inconvenience this incident has caused to your service.
Thank you,
1GLOBAL Major Incident Team

March 17, 2026 · 13:06 GMT
Update

Dear Customer,

We are continuing to follow up on the registration incident in the Philippines impacting Voice, Data, and SMS services.

Our KPIs already show some improvements; nevertheless, we can still see some impact on our services.

We continue to push our partners for a structural resolution.

We expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

March 17, 2026 · 11:01 GMT
Update

Dear Customer,

We are continuing to follow up on the registration incident in the Philippines impacting Voice, Data, and SMS services.

We are actively in communication with our partners to mitigate the impact as soon as possible.

We expect to provide an update as soon as we have relevant information.

Thank you,
1GLOBAL Major Incident Team

March 17, 2026 · 09:28 GMT
Update

Dear Customer,

We continue to follow up on the impact on Voice, Data, and SMS services in the Philippines.

We have escalated a high-priority ticket with our partners.

We expect to provide an update as soon as we have relevant information.

Thank you,
1GLOBAL Major Incident Team

March 17, 2026 · 08:33 GMT
Issue

Dear Customer,

We are currently experiencing service registration issues in the Philippines for our customers connected to Globe Telecom.

This may impact Voice, Data, and SMS services, and customers may experience an intermittent “No Service” or “SOS” status on their devices.

The 1GLOBAL major incident team is currently troubleshooting this behaviour and working towards stabilising these services as soon as possible.

We expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

March 17, 2026 · 08:28 GMT

← Back