Provisioning & Service Portals Experiencing Difficulties

Major incident Portals Customer Support | Support.jira.1global.com Account Management Portal (my.truphone.com) Remote SIM Provisioning RSP Management Portal Connect API API Connect API - V2 Connect API - V3 IoT Web Portal API
2026-07-17 03:00 BST · 2 hours, 4 minutes

Updates

Resolved

Dear customer,

Through our service performance indicators, we confirm that all services are available and backlog of pending actions has been consumed successfully.

We will closely monitor our service for 48 hours to ensure long-term stability.

For any inquiries or additional help, don’t hesitate to contact your usual support channels and points of contact.

We apologize for any inconvenience this incident has caused on your service.

Thank you,
1GLOBAL Major Incident Team

July 17, 2026 · 04:56 BST
Update

Dear Customer,

We can confirm that we have restored our services and we see our KPIs returning to normal.

The 1GLOBAL Major Incident team is currently assessing the propagation of this fix across our network and preforming sanity checks across all services.

This incident will continue open until we fully confirm our services and process provisioning backlog.

We expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

July 17, 2026 · 04:37 BST
Update

Dear Customer,

We are continuing to follow up on the impact in our provisioning & API ecosystem.

Current services & Portals Impacted:
-Provisioning for 1GLOBAL Infrastructure

  • Activations, Terminations, Subscription lifecycle management.
  • Enterprise, Connect & IoT APIs,
  • B2B Portal,
  • IoT Ecosystem
  • IoT Portal Access
    • IoT Rules, suspending and unsuspending SIM cards
    • IoT Block/Unblock SIM cards upon country change if rules are configured for such.
  • BetterRoaming Portal,
  • RSP Portal,
  • MyTruphone & BetterRoaming Aplication

The 1GLOBAL major incident team has identified the root cause of this behaviour and is currently applying the fix in our IP network.

We expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

July 17, 2026 · 04:29 BST
Update

Dear Customer,

We are continuing to follow up on the impact in our provisioning & API ecosystem.

Current services & Portals Impacted:

  • Provisioning for 1GLOBAL Infrastructure
    • Activations, Terminations, Subscription lifecycle management.
  • Enterprise, Connect & IoT APIs,
  • B2B Portal,
  • IoT Ecosystem
    • IoT Portal Access
    • IoT Rules, like suspending and unsuspending SIM cards.
  • BetterRoaming Portal,
  • RSP Portal,
  • MyTruphone & BetterRoaming Aplication

The 1GLOBAL major incident team continues to troubleshoot this incident and is currently working on applying mitigation actions across our network.

We expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

July 17, 2026 · 04:13 BST
Update

Dear Customer,

We are continuing to follow up on the impact in our provisioning & API ecosystem.

Current services & Portals Impacted:

  • Provisioning for 1GLOBAL Infrastructure
    • Activations, Terminations, Subscription lifecycle management.
  • Enterprise, Connect & IoT APIs,
  • B2B Portal,
  • IoT Portal,
  • BetterRoaming Portal,
  • RSP Portal,
  • MyTruphone & BetterRoaming Aplication

The 1GLOBAL major incident team identified an IP misconfiguration in one of our systems and is currently troubleshooting this behaviour and working towards stabilising these services as soon as possible.

We expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

July 17, 2026 · 04:02 BST
Issue

Dear Customer,

We are currently experiencing difficulties in our Order Manager, our provisioning orchestrator and internal portals such as:

  • IoT Portal
  • B2B Portal
  • BetterRoaming Portal

Customers will be unable to access our portal websites and be unable to fulfill any provisinoning requests such as activations, terminations and changes in the fifecycle of the subscription.

The 1GLOBAL major incident team is currently troubleshooting this behaviour and working towards stabilising these services as soon as possible.

We expect to provide an update as soon as we have relevant information to share.

Thank you,
1GLOBAL Major Incident Team

July 17, 2026 · 03:40 BST

← Back