Intermittent slow data speeds in EMEA

Minor incident Enterprise/Compliance Connectivity Data Services Australia France Germany Hong Kong Netherlands Poland Spain United Kingdom United States Roaming Connect API Data Europe Asia
2026-08-03 19:19 BST · 3 hours, 58 minutes

Updates

Resolved

Dear Customer,

The issue affecting mobile data and internet services for some customers across Europe has now been mitigated, and services have returned to normal.

The incident was caused within our third-party carrier’s network. During the incident, traffic was rerouted across redundant network paths where possible to minimize customer impact while the underlying issue was being addressed.

We will continue to monitor the service closely to ensure ongoing stability.

We apologize for any inconvenience this incident may have caused and thank you for your patience and understanding throughout the resolution

Thank you,
1GLOBAL Major Incident Team

August 3, 2026 · 23:17 BST
Investigating

Our investigation is ongoing in collaboration with our third-party carrier. They continue to investigate and remediate the problem.

To reduce customer impact, we have successfully rerouted the majority of traffic through our secondary network paths. While this has improved overall service stability, we are aware that some traffic remains congested and may still experience intermittent degradation or reduced data performance.

The 1GLOBAL Major Incident team remains engaged with and is monitoring the situation closely. We will continue to provide updates as progress is made.

August 3, 2026 · 20:54 BST
Investigating

Dear Customer,

We are currently experiencing a degradation affecting mobile data and internet services for some customers across Europe.

Our investigation has identified the issue as being related to a third-party IPX carrier. As a result, some customers may experience intermittent periods of reduced data performance or slower internet speeds.

The 1GLOBAL Major Incident team is actively working with the affected third-party provider to resolve the issue as quickly as possible. In parallel, we are implementing traffic rerouting across redundant network paths to improve stability and minimize customer impact.

We will continue to provide updates as more information becomes available. Thank you for your patience and understanding.

Thank you,
1GLOBAL Major Incident Team

August 3, 2026 · 19:19 BST

← Back