IoT Portal - Unavailable

Major incident Portals Connectivity Management (iot.truphone.com)
2023-04-23 16:28 BST · 1 hour, 39 minutes

Updates

Issue

Truphone’s Iot Portal is currently unavailable. Our engineering teams are investigating the issue.
Updates will be provided as soon as possible.

May 22, 2023 · 12:08 BST

← Back