Customer Support - Portal Unavailable

Major incident Portals Customer Support | Support.jira.1global.com
2023-06-30 23:16 BST · 1 hour, 27 minutes

Updates

Resolved

This issue has now been resolved.

July 1, 2023 · 00:02 BST
Investigating

Truphone customer support portal is currently unavailable. We are currently working to fix this issue and updates will be provided as soon as they’re available.

June 30, 2023 · 23:16 BST

← Back