Greece - Registration Issues Detected

Minor incident Connectivity Data (Europe)
2023-09-20 13:56 BST · 4 hours, 23 minutes

Updates

Resolved

This issue has now been resolved.

September 20, 2023 · 18:14 BST
Issue

We detected an issue with data registration in Greece with one of the two operators 1GLOBAL works with. We’re currently investigating this issue with our partner and updates will be provided as soon as they’re available.

September 20, 2023 · 13:56 BST

← Back